ClubControl

ClubControl - лучшая программа для управления клубом.

Начать работу

Настройки сервера , клиента

Таблица

Трафик


Установка

Для работы системы необходимо следующее :

  • Установить программу на игровой компьютер, запустив файл ClubControl3Client.exe и следуя инструкциям на экране.
  • Указать адрес сервера.
  • Указать номер компьютера (номер по умолчанию =1).
  • Создать папку (или указать ее расположение) для ярлыков.
  • Создать игровые разделы.
  • Создать ярлыки к играм/программам.

Все это, кроме указания номера компьютера, может быть выполнено для одного компьютера и затем скопировано на остальные при установленных драйверах WinPcap (файл WinPcap_2_3.exe). См. раздел настройка.

Пример :

  1. Устанавливаем ClubControl3Client на первый компьютер в папку C:\CCC.
  2. Создаем папку c:\ccc\shortcuts.
  3. Запускаем файл ClubControlClient.exe.
  4. Нажимаем Escape, выбираем логин Administrator, вводим пароль по умолчанию "111". Программа в админском режиме.
  5. Выбираем пункт меню Вид / Настройки.
  6. Вводим номер компьютера (1) и адрес сервера "server" (без кавычек) в разделе.
  7. Рекомендуется также выбрать пункт "Заменить Windows Explorer Shell" в разделе "Безопасность".
  8. Нажимаем Ок.
  9. Для того, чтобы изменения вступили в силу, программу надо перезапустить. Самый удобный способ - меню / Сменить пользователя.


Настройка

Настройки из интерфейса

Главное окно - то, что видит посетитель. Устанавливается цвет фона (не имеет значения при выбранной большой фоновой картинке) и цвет шрифта при ярлыках.
Фоновая картинка выводится по центру. Цвет названия клуба не должен сливаться с цветом фона. Параметры contrast определяют, как сильно должна отличаться цвета при случайной генерации (0 - 250), 0 - допускаются одинаковые цвета, 250 - максимальная разница.
"Маленькие значки" - размер ярлыков в заставке (16х16 / 32х32).
"Пульсирующий номер компьютера" - будет ли дергаться этот номер в заставке.

В Папке с ярлыками хранятся папки, названия которых соответствуют имеющимся игровым разделам (обычные папки) и тарифам (скрытые папки). Существует отдельный раздел "Управление" : при наличии папки "Управление" он показывается в режиме Админа.

Стандартный регулятор громкости может выводиться в 3х видах :

  1. Крошечный - параметр -t. Наиболее безопасный вариант.Доступна только общая громкость.
  2. Небольшой - параметр -s. Полновункциональный регулятор уменьшенного размера. Внимание! Доступен вызов справки - если в запрещенных процессах не указан файл hh.exe - дырка в безопасности .
  3. Нормальный - большой небольшой:).

Имя сервера - может быть NetBios/DNS или IP-адрес.
Номер компьютера - как компьютер будет обозначен на сервере, должен быть уникален.
Порт - порт TCP на сервере. Менять нужно, если только объявилась программа, претендующая на владение такой же цифрой.
Время между попытками соединения - как часто отключенный клиент пытается установить связь с сервером.
Кол-во игр в рейтинге - проголосовать можно только при попадании числа выбранных игр в заданные рамки.

Кнопки F8 & Ctrl - безопасный режим загрузки windows - для того, что бы не могли убрать ССС из автозагрузки.
Замена Shell'a - убирает стандартный интерфейс Explorer.
Перезагрузка после завершения времени - рекомендуется для "очистки" компьютера после игр. Дается задержка до перезагрузки, см. дополнительные параметры.
Автономная работа - при вводе пароля можно изменить оставшееся время, работает только при отключенном сервере (для экстренных случаев).

Убрать из Explorer'a - стандартные ограничения windows реестра.
Доступ к дискам - прячутся диски в МоемКомпьютере.
"NoRun" - запрещается запуск программ, файлов и папок из адресной строки Internet Explorer'a.
"NoNetHood" - не показывается значек "Сетевое окружение" на рабочем столе windows.
"NoSetFolders" - запрещается доступ к настройкам windows (Control panel, Network connections...)/
"NoControlPanel" - запрещается доступ к панели управления windows.
"NoFolderOptions" - запрещается доступ к свойствам папки.
"NoPlacesBar" - из стандартного диалога "Открыть/Сохранить файл" убирается быстрый доступ к рабочему столу, моимдокументам, последнимдокументам и т.п.
"NoNetworkConnections"- прячется значек Сеть.
"NoSetTaskbar" - запрещается доступ к настройкам панели задач.
"NoDesktop" - прччется все с рабочего стола.
"NoInternetIcon" - прячется Internet Explorer c Рабочего стола.
"NoFileMenu" - прячется меню Файл из проводника.
"NoViewContextMenu" - прячется контекстное меню правой кнопки мыши из проводника и стандартных диалогов "Открыть/Сохранить файл" (но остается возможность удаления файлов по кнопке Delete).

Запрещенные процессы

Для каждого тарифа можно указать программы, которые не будут запускаться в режиме Пользователя. Эти запреты действуют независимо от того, кто и откуда пытается запустить программу. В некоторых играх существуют ссылки на интернет-сайты или другие "внешние" места, из которых можно что-то испортить в системе. Эта проблема решается с помощью запрещенных процессов. В основном, следует запретить Explorer.exe во всех тарифах и Internet Explorer (Program Files/iexplore.exe): игрокам останется только играть !
Для добавления запрещенной программы : выделите тариф ,нажмите кнопку Добавить , выберите Пункт "Добавить программу" и выберите нужную программу (exe-файл) . Можно запретить целый путь - из это папки и всех под-папок ничего не запустится.
Для удаления запрета : выделите запрещенную программу (путь) и нажмите Удалить. При этом будет запрошен пароль. После ввода правильного пароля он не будет спрашиваться при последующих удалениях или при смене пароля.

В ини-файле есть доп. параметры диалога "Время вышло" (раздел [Security]):

DelayNo - время до автоматического нажатия кнопки "До свидания"
DelayYes - время, прибавляющееся при нажатии кноаки "Доплатить и продолжить"
AddForRating - прибавка на голосование
ForceAutoReboot - "жесткая" перезагрузка (не рекомендуется).

Все настройки доступны с сервера.


Интерфейс

В режиме пользователя на экране видны следующие элементы :

  • Рабочий стол. На него может быть выведена картинка, изменены цвета. Тут лежит главное - ярлыки.
  • Кнопка меню - [image] при подключенном сервере она цветная, в появляющемся меню дублируются ярлыки с рабочего стола + поддерживаются вложенные папки. Серый значек у названия раздела/папки обозначает тариф (атрибут "скрытый") Первый пункт меню - Сервис, откуда доступны следующие функции :
    • Позвать админа - при нажатии на сервере вылезает сообщение и этот пункт отключается на 5 минут.
    • Восстановить размер экрана - если после игры экран "скрючило", то будут воосстановлены параметры, запомненные при запуске системы.
    • Чат - общение с другими пользователями / админом. Исходящие сообщения - красный шрифт, Входящие - синий. В правой части выделяются компьютеры, которым направлено сообщение. Если не выделен ни один , сообщение идет на сервер.При отключении сервера окно закрывается.

  • Кнопка программы [image] - содержит меню с запущенными программами. При выборе пункта программа выходит на передний план (Alt-Tab).Хаотично, но плавно меняет цвет.

  • При включенном тарифе интернета виден счетчик трафика [image].
  • Закладки [image] - см. разделы.
  • Время [image] - текущее / оставшееся. При посадке без предоплаты и без ограничения показывает оставшееся до конца смены время, при посадке по клубной карте - оставшееся на карте время.
  • Мыльная кнопка - доступ к "Быстрой почте". Вид кнопки зависит от файлов, указанных в разделе [CLUBCONTROLCLIENT] (параметры MailBitmapOn (нажатая) и MailBitmapOff (обычная)).Формат картинок - несжатый bmp, размер ЛЮБОЙ, верхний левый пиксель - обозначает прозрачный цвет (форма кнопки).
  • Регулятор громкости [image] - требует щелчка левой кнопки мыши.

Виды рабочего стола

Список, Значки, Детали, Простой список - определяется размер ярлыков, их расположение. В виде "Детали" видны две колонки : слева иконка с названием, справа описание. Описание берется из ярлыка windows, его можно изменить из меню или (в ОС win Me , 2000 & XP) из свойств самого ярлыка.

Возможно не показывать список разделов в виде закладок внизу а на рабочем столе разместить ярлыки из одного определенного раздела (папки). Для этого в настройках клиента на сервере в разделе "Интерфейс" в поле "Доступ к ярлыкам" нужно вписать название любого нескрытого раздела.

В заблокированном режиме слева выводится список доступных ярлыков. Между номером компьютера и названием клуба(интернет кафе) может размещаться кнопка входа в систему (в папке с файлами клиента должны лежать файлы LoginButtonOn.bmp и LoginButtonOff.bmp). Нажатие на нее равноценно нажатию на Escape (появляется окно ввода имени/пароля).


Состояния

Клиент работает в 3х режимах : Администратора, Пользователя, Заблокированный.
В Заблокированном режиме невозможны операции с запущенными программами, на экран выведена заставка и работает только кнопка ввода пароля (обычно Escape).

В режиме пользователя возможен запуск ярлыков, включены запреты на запуск программ, по истечении времени компьютер блокируется. К настройкам доступа нет. Так же доступен регулятор громкости, сервисные функции, переключение между программами, выбор разделов.

В режиме Администратора возможно то же, что и в Пользовательском + появляется меню, раздел "Управление" (если создана соотв. папка), открываются ВСЕ разделы, отключается система запрещенных процессов, доступны контекстные меню. По окончании времени клиент НЕ БЛОКИРУЕТСЯ.

С определенным интервалом и при изменении текущее состояние отсылается на сервер и там заносится в файл сс2. Локально переход между состояниями осуществляется по кнопке Escape. Для входа в режим Админа требуется пароль. Из режима пользователя компьютер автоматически перейдет в Заблокированный , если у него нет добавленного времени.


Разделы/Тарифы

Разделы

Можно разбить имеющиеся в клубе игры на разделы, такие как Стратегии, Гонки и т.д. В нижней части экрана находятся "закладки", названия которых соответствуют темам. При нажатии на закладку загружаются ярлыки из папки, лежащей в "основной папке ярлыков" и называющейся так же, как и раздел (регистр не имеет значения). Разделы можно создавать из программы или просто создавая папки. Папки разделов не должны иметь атрибут "Скрытая". Разделы(закладки) загружаются при запуске программы и при добавлении / удалении их из программы. В закладках разделы выводятся в порядке даты их создания. Пункты меню (и контекстного меню) :

Добавить раздел - создается новая папка и новая закладка. Этот раздел становится активным (выбранным).
Удалить раздел - удаляется папка со всеми ярлыками в ней и закладка. Следующий раздел становится активным.
Открыть раздел - открывается папка в explorer'e. Полезно для доступа к свойствам ярлыков.
Открыть папку с ярлыками - открывается папка, содержащая папки разделов.

Скрытые разделы (папки с атрибутом Скрытая) появляются при добавлении времени по соответствующему тарифу и пропадают при изменении тарифа. При добавлении времени по тарифу, для которого не существует папки, раздел не показывается.

Существует системный раздел "Управление". Если создана такая папка, то он будет появлятся в режиме Админа (в котором показываются все разделы). Там удобно держать ярлыки на диски, служебные программы и т.д.


Быстрая почта

Отправка электронной почты по протоколу smtp. Не требует исходного почтового ящика. Доступно при оплаченном тарифе Интернет. Используемый сервер, порт и почтовый аккаунт настраивается с сервера. На сервере mail.ru создана специальная учетная запись ClubControl@mail.ru - ее можно использовать, но ее существование не гарантировано. Рекомендуется установить в клубе SMTP-сервер и использовать его. В Windows 2000 и выше легко использовать IIS.

Для отправки необходимо ввести адрес и (тему или сообщение).


Настройки сервера

Основные

Пункт меню Вид / Настройки (кнопка F10).

  • Начало смены , Начало/конец ночи : Отчетность в ClibControl посменная, длительность смены 24 часа. Этот интервал показывается по умолчанию в графической таблице и в отчетах. В смене отдельно выделяется Ночь - при добавлении такого времени в списке компьютеров появляется знак Ночь.... Указываются только часы.
  • Округлять стоимость : При автоматическом подсчете стоимости деньги будут округлены до целого числа.
  • Пауза между пользователями : При достаточной загруженности клуба можно резервировать время для посетителей. Что-бы "игрок" понял что его время вышло и надеятся больше не на что, необходимо какое-то время (напр. 30 сек.) подержать компьютер в заблокированном состоянии. При нажатии Enter или Двойном щелчке левой кнопкой мыши на ЗАНЯТОМ компьютере программой будет предложено время , равное времени окончания работы текущего пользователя + указанное время .
  • Порт : Практически не меняющийся параметр. Может оказаться полезным, только если обнаружится программа, использующая такой-же порт. Должен совпадать с портом , указанным на Клиенте.
  • Интервал проверки связи : как часто клиент должен отсылать сигнал о том, что он работает.
  • Запоминать последнее добавленное время : при включенной опции после вызова диалога добавления времени в поле "Длительность" будет вписано последнее время, при выключенной - 00:00:00.
  • Автоматический (без Ctrl+Enter) пересчет деньги->время : в диалоге добавления времени при изменении суммы будет менятся и длительность по прайсу (сколько времени можно посидеть на Х денег ?). Таким образом ,невозможно ввести другую стоимость, кроме как расчитываемую программой из прайса. Если же позволяется иногда вручную подкорректировать стоимость, то эта опция должна быть выключена (пересчет деньги - время можно совершить вручную, нажав Ctrl+Enter).
  • Разрешить пост-оплату : можно ли открывать сеансы без предоплаты и брать деньги по факту использования.
  • Использовать регистрацию администраторов : при запуске сервера СС будет запрашиваться имя пользователя и пароль, пользователям можно ограничивать права, в отчетах будет храниться информация о том, какой пользователь сервера продавал время.
    При отключенной опции имя пользователя будет браться из windows (текущий), но права в системе ClubControl ограничивать будет нельзя. Важные настройки защищены от изменения общим паролем (см. ниже).
  • Требовать старый пароль при включении режима админа при смене : Нужно ли знать старый пароль для того что бы сменить его. При отключенной опции пароль мгновенно меняется просто вводом нового пароля.
  • Разрешить изменение тарифов в процессе испоьзования времени :
  • Папка с данными : Там будут сохраняться основные данные в файлах с расширением .cc3. При каждом изменении / добавлении в существующий файл финансовой информации (время / дополнительные услуги) в этой же папке создается копия файла (прибавляется расширение .bak). Файлы называются в формате ГГГГ ММ ДД.сс3 . Таким образом, на каждую смену существует отдельный файл и его резервная копия (в которой финансовой информации может быть меньше на одно действие администратора).
  • Папка с прайсами : Там лежат прайсы, один на день недели (Monday.price, ...).
  • Папка с обновлениями : Файлы, помещенные сюда, по команде Клиент / Дополнительно / [image] Послать новую версию отсылаются выбранным клиентам. Клиент после получения последнего файла выключается, заменяет старые файлы новыми и запускается опять. Можно посылать любые файлы, они окажутся в папке с ClubControlClient.exe (по умолчанию C:\CCC) c приписанным расширением .new, которое после перезапуска клиента будет отрезано. Папки таким способом не копируются.
  • Сообщение в заданное время : админу будет задан вопрос о необходимости отсылки собщения всем клиентам и при положительном ответе оно будет отправлено. Формат сообщения - как у "Быстрых сообщений".
  • Смена пароля : поменять пароль, используемый для сети ClubControl и изменения учетных записей пользователей сервера.

Выключите программу для создания файла с настройками (если его нет).

Дополнительные

Трей Можно задать пароль на выход из трея : щелкните правой кнопкой мыши на иконке и выберите пункт "Сменить пароль". Введите новый пароль.

Настройки сообщений области уведомлений Windows 2000/XP
О некоторых событиях пользователю сервера сообщается с помощью вылезающих из "трея" "баллонов" :
Сообщение из трея
Из диалога настроек, вызываемого из пункта меню "Сообщения", можно выбрать, какие сообщения будут выводиться и как долго они будут оставаться на экране.
  • Изменение состояния клиента - переключение клиентского компьютера между режимами Пользователя, Администраторским и заблокированным.
  • Отключение клиента - отключение клиентской части ClubControl законным способом.
  • Подключение клиента - подсоедиение клиентской части ClubControl к серверу.
  • Потеря связи - неполадки с сетью, или завис клиентский компьютер.
  • Сообщение администратору - с клиентского компьютера было отправлено сообщение админу (чат).
  • Сообщение клиенту - позволяет контролировать сообщения чата между посетителями.
Настройки в файле cc.ini.
  • Предупреждения перед окончанием времени (сеансов)
    Раздел [ClubControl]
    ;Количество секунд до окончания времени для выдачи предупреждения TimeEndWarningMessage1, 0-не выводить
    TimeEndWarningTime1=60
    ;Сообщение 1. %i заменяется на номер компьютера. Можно использовать ыормат быстрых сообщенй (тип, цвет, длительность и т.п.)
    TimeEndWarningMessage1=У компьютера №%i осталась минута времени !/L=5

    ;Количество секунд до окончания времени для выдачи предупреждения TimeEndWarningMessage2, 0-не выводить
    TimeEndWarningTime2=10
    ;Сообщение 2. %i заменяется на номер компьютера. Можно использовать ыормат быстрых сообщенй (тип, цвет, длительность и т.п.)

    TimeEndWarningMessage2=У компьютера №%i заканчивается время !/L=5
  • Автоматическое создание резервных копий данных
    Раздел [ClubControl]
    Параметр MultipleBackups=0
    0=создавать только одну копию (.bak)
    1=создавать копии при каждом изменении данных, к имени файла добавляется время в формате .ЧЧ-ММ-СС.bak
  • Максимальный размер файла журнала
    Раздел [ClubControl]
    Параметр LogSize=3145728 (Размер в байтах)


Prices

Прайсы

При добавлении времени ("посадка" клиентов) стоимость расчитывается исходя из заранее введенных цен, хранящихся в т.н. прайсах.

Цены разбиты по тарифам и времени суток.
Формат прайса :

[<тариф> <час начала>-<час окончания>]
<длительность в минутах>=<стоимость>
<длительность в минутах>=<стоимость>
...
<длительность в минутах>=<стоимость>

Пример

[game 12-20]
60=15
120=28
180=40

[game 20-23]
60=10

При таких ценах в указанное время (с 12 до 20 ч.)
30 мин. будут стоить 7.5 (р.),
1ч-15,
2ч-28,
3ч-43 (считается как 2ч+1ч),
4ч-56.

При попадении времени в два и более временных диапазона (напр. с 19ч до 22ч) цена расчитается для каждого временного отрезка отдельно - в указанном примере первый час (с 19 до 20) будет стоить 15 + следующие два часа (с 20 до 22) будут стоить 10*2 = 20, итого 15 + 20 = 35.

Прайсы разбиты по дням недели и группам компьютеров.

Группы компьютеров.

Возможно разделение цен по компьютерам (группам или залам). Это определяется в редакторе прайсов (закладка Группы).

Формат следующий :

[<название группы>]
<номер компьютера>-<номер компьютера>
<номер компьютера>-<номер компьютера>
...
<номер компьютера>-<номер компьютера>

Пример

[обычные]
1-15
20-30

[VIP]
16-19

В группе "обычные" находятся компьютеры с 1 по 15 включительно и с 20 по 30 включительно. В группе "VIP" компьютеры с 16 по 19.

Редактор прайсов

Слева находятся закладки с днями недели (+ специальная для редактирования групп) , при нажатии на закладку в окне редактирования (справа) появляется содержимое соответствующего прайса или конфигурация групп. Прайсы показываются для группы , выбранной в списке групп (на рис. - "default") После внесения изменений для сохранения всех прайсов группы нужно нажать кнопку "Сохранить группу". При выборе другой группы несохраненные изменения пропадают. При переключении закладок сохранять данные не нужно.

Дополнительные возможности.

Точные пакеты времени.

При необходимости задать цены на точные пакеты времени (пакет строго определенной длительности в строго определенное время) можно добавить следующие блоки в прайсы :

[<тариф> <час начала>-<час окончания> exact]
<длительность в минутах>=<стоимость>

Пример

[game 10-12 exact]
120=20

- 2 часа строго с 10 до 12 будут стоить 20 (р.)

Цены на трафик.

Для включения интернета достаточно добавить раздел

[<название тарифа> traffic <количество бесплатного трафика в Кб на 1 час>].

Напр. [интернет traffic 1024]
-при добавлении 1 часа времени по тарифу "интернет" клиент сможет скачать 1 Мб.
-при добавлении 30 мин времени по тарифу "интернет" клиент сможет скачать 512 Кб.
-при добавлении 2 часов времени по тарифу "интернет" клиент сможет скачать 2 Мб.

Внутри этого раздела можно задать стоимость дополнительного трафика, добавляя строчки :

<минимальный объем в Кб>=<цена за 1 Мб>

Пример

[интернет traffic 1024]
0=5
5120=4
10240=3

что означает : при использованном трафике от 0 до 5 Мб стоимость будет расчитыватся исходя из цены 5 р./Мб., от 5 до 10 Мб - по 4 р., больше 10 Мб - по 3.

Минимальная стоимость.

Можно задать минимальную стоимость для каждого тарифа :

Добавьте раздел
[MinCost]

Содержание раздела :

[MinCost]
<название тарифа>=<минимальная стоимость>
<название тарифа>=<минимальная стоимость>
...
<название тарифа>=<минимальная стоимость>

Пример

[MinCost]
Internet=10
Game=5

- При добавлении времени по тарифу Internet на 7 (на сумму, меньшую 10) (р.) будет указана стоимость 10 (р.).


Email Reports

Отчеты по электронной почте

Могут отправляться по заданному из меню Файл/Отчеты по e-mail расписанию . Расписание

Настройки :

Почтовый сервер : Необходимо иметь relay SMTP сервер (см. Быстрая Почта)


Включение сервера

Включение

Сервер запускается файлом ClubControl.exe из директории установки или через ярлык ClubControl в меню Start / Programs.

Если в настройках задействована система учетных записей пользователей сервера (Пункт "Использовать регистрацию администраторов"), то для входа необходимо ввести имя пользователя и пароль.

Авторизация пользователя сервера ClubControl

Описание работы с учетными записями смотрите тут.

Через несколько секунд (зависит от настроек) подключатся клиентские компьютеры, что будет видно по Списку компьютеров.

Если ClubControl уже запущен, то появится предупреждение :

Занят сетевой порт

При нажатии на кнопку Ок программа запустится в режиме просмотра : Т.е. клиенты не будут подключены и манипуляции со временем не будут иметь на них действия. В списке компьютеров все компютеры будут Unconnected Free или Unconnected Busy . Клиенты в это время могут быть подключены к ранее запущенному серверу.
Этот режим может пригодиться для просмотра файлов с данными (.сс3) без отключения клиентов.

При запуске программа загружает файл, названный по сегодняшней дате и все более поздние (если они есть), в которых может находится информация о зарезервированном вперед времени.
Процесс загрузки отображается в заголовке окна

Если есть зарезервированное на завтрашний(или далее) день время, то в заголовке окна останется не сегодняшняя дата, а дата последнего загруженного файла.

При обнаружении испорченных данных в загружаемом файле будет показана табличка :

Если данные повреждены в середине или еще ближе к началу файла, то обрезание приведет к потере большой их части. В особых случаях можно сохранить поврежденный файл и его резервную копию и отправить нам на экспертизу.

При нажатии (двойном щелчке левой кнопкой мыши:) на файле сс3 запустится сервер в режиме просмотра и загрузит этот файл. Таким методом можно открыть 1 файл одновременно. Расширение сс3 регистрируется при первом запуске программы из новой директории.


Выключение сервера

Выключение

Сервер (как и клиенты) может включатся и выключаться в любое время. При выключенном сервере клиенты корректно завершат текущий сеанс (компьютеры вовремя заблокируются). Но следует учитывать, что при долгом отсутствии сервера в таблице появятся пустоты.

Некоторые ограничения : при отсоединенном сервере на клиентах пропадает возможность вызова администратора, недоступен Чат, голосование, регистрация посетителя.

Рекомендуется держать сервер постоянно работающим и перезапускать в начале или в конце смены, что бы сменился период отображаемой информации (в таблице и списке). Об этом будет напоминать табличка, появляясь в момент окончания Ночи (параметр NightStopHour).


Добавление времени

Операции со временем можно проводить не зависимо от того, подключены ли компьютеры к серверу. Однако, без наличия связи с выбранными компьютерами, имеют смысл только действия, выполнение которых может быть отложено до момента подключения (например, можно добавить время компьютеру, который перегружается - когда он подключится , сервер укажет ему правильное состояние).

Главный инструмент администратора

Добавление времени, или "открытие компьютера", призводится через отдельный диалог (окошко) :

Главное админское окно

Отсюда возможно добавление времени , т.е. "посадка клиента", 3-мя способами :

  1. Предоплата - Самый распространенный "метод" - посетитель называет время; админ вводит его в поле "Длительность"; цена показывается в рублях (исходя из прайса); посетитель дает деньги; админ пробивает чек и проверяет соответствие его номера (поле "Чек"); заканчивается сия процедура нажатием на кнопку "Добавить" или Enter.
    Выбранным компьютерам тут же (или, если они не подсоеденены, в момент следующего подключения) отошлются новые данные и они разблокируются в течение 5 сек.
    Галочка "Предоплата" должна быть поставлена (как на рисунке выше).
    Возможен пересчет Деньги->Время ("можно мне на 100 р. ?"), нужно ввести сумму и нажать Ctrl+Enter, расчитанное время занесется в поле Длительность. Если в настройках сервера включен "Автоматический пересчет деньги->время", то Ctrl+Enter нажимать не надо, длительность будет считаться автоматически при изменении стоимости.
  2. Постоплата - Можно ничего не вводить и сразу жать кнопку "Добавить" (если, конечно, выбраны нужные компьютеры). В таком случае клиентам будет выделен кусок времени, начинающийся с данного момента и оканчивающийся вместе с рабочей сменой.
  3. Клубная карта - При вводе номера в поле "Клубная карта" (см след. рис.) отключается кнопка "Предоплата", и если введен существующий номер, то в поле "Длительность" указывается оставшееся по карте время или номер выделяется красным цветом. Поле для ввода № кк находится в дополнительной части (кнопка Кнопка расширения ). Если у карты есть фотография, то при вводе номера справа выдвинется окошко с уменьшенной копией фотографии.
    Для того, что бы при вводе каждой цифры длинного номера не производился поиск фотографии (тормоза на некоторых компютерах) существует задержка, настраиваемая из файла cc.ini :[AddTime Dialog] раздел,параметр ShowPhotoDelay=1000 (в мс). На быстрых компьютерах можно написать ShowPhotoDelay= 0.< /FONT>
    Также см. Оформление КК.

swf

Операции со временем можно проводить не зависимо от того, подключены ли компьютеры к серверу. Например, если клиент перезагружается и нужно принять деньги при пост-оплате, то не нужно ждать, пока он подключится. Однако, без наличия связи с выбранными компьютерами, имеют смысл только действия, выполнение которых может быть отложено до момента подключения (например, можно добавить время компьютеру, который перегружается - когда он подключится , сервер укажет ему правильное состояние).

Дополнительные возможности

Указав конкретное время начала работы компьютера, можно резервировать время.См пауза между пользователями.

В Примечаниях можно что-то написать и увидеть написанное в отчетах и списке времен.

Если какие-то данные неправильны или конфликтуют с уже введенными, то кнопка "Добавить" блокируется и соответствующие поля выделяются красным цветом.

При вводе времени начала, совпадающего со временем окончания ранее добавленной записи включается режим продления.

При вводе времени, соответствующего началу и концу ночи, иконка в верхнем левом углу меняется на

В файле cc.ini в разделе [AddTime Dialog] можно изменить следующие параметры :

SavePrepaidState=0/1
Запоминать положение галочки предоплаты (=1) или нет (=0)

FixedTariff=<название тарифа>
Если указан какой-нибудь тариф (например FixedTariff=internet), то при вызове диалога в поле "тариф" будет именно он, если же там пусто, то - в поле "тариф" будет последний использовавшийся тариф.

CanAddFutureTime=0/1
Можно ли добавлять время, выходящее за рамки текущей смены, 0-нельзя, 1-можно.

SaveTime=0/1
Запоминать ли последнее добавленное время, 0-нет, 1-да.

Timer=0/1
При вызове диалога поле временем начала сеанса ставится текущее системное время. Если "долго думать", то при добавлении времени окажется, что несколько секунд/минут у посетителя пропало. Значение параметра =1 помогает, постоянно подстраивая время начала сеанса под текущее.

Как выбрать компьютеры ?

Перед тем, как добавить время, нужно выбрать компьютеры (Так же без компьютеры можно выбирать/менять выбор и после занесения остальных данных). Это делается или из списка компьютеров выделением стандартными методами (дополнительные кнопки - Ctrl, Shift, Space и т.д.) или из графической таблицы.

Где найти это окошко "Добавление времени" ?

Выбрав (или не выбрав :) компьютеры, можно :

  • В графической таблице (F3) - Нажать Enter или Двойной щелчек левой кнопкой или из меню выбрать пункт Время / [image] Посадить...
  • В списке компьютеров (F4) -Нажать Enter или Двойной щелчек левой кнопкой или из меню выбрать пункт Время / [image] Посадить... или в верхнем правом окошке (список времен) нажать правую кнопку мыши и выбрать пункт [image] "Посадить..."

Авто-определение времени посадки

Если СНАЧАЛА выбрать компьютеры а потом вызвать диалог "Добавление времени" , то в поле "Время С" занесется :
текущее время, если сейчас все выбранные компьютеры свободны;
самое позднее время окончания , если хотя бы один компьютер занят. Таким образом, нажимая Enter и добавляя , например, по 1 часу на одни и те же компьютеры, получим последовательность отрезков времени длиной 1 час и с заданной настройками "паузой между пользователями".На одно действие требуется всего 3 нажатия на кнопки.

Ни минуты простоя !


Продление времени

Выберите нужное время :
из списка (F4) - выделите компьютеры и нажмите Shift+Enter для ускоренного выбора или выделите в списке компьютеров нужные строчки и щелкните правой кнопкой мыши для появления контекстного меню

Продление времени из списка компьютеров

или в списке времен

Продление времени из списка времен

Продление нескольких компьютеров одновременно возможно только если выбранное время оканчивается одинаково (с точностью до 1сек). В обратном же случае нужно продлевать по-отдельности.

Из таблицы можно продлевать время только для одного компьютера одновременно, щелкнув правой кнопкой на нужном и выбрав пункт Продление "Продлить...".

При продлении уже добавленное (продлеваемое) время не меняется, а "вплотную" к нему добавляется новое время - т.е. если вручную добавить новое время, начинающееся строго в момент окончания предыдущего времени на этом компьютере, то это и будет продлением. У добавленного времени присутствует системное примечание "(продление)".

Примечание о продлении в Таблице


Перенос времени

При переносе текущего времени оно разбивается на 2 части : 1я часть остается на месте и укорачивается, а остаток переносится на выбранный компьютер.

Сохранение денежного баланса :
Если переносится уже оплаченное время, то в 1ой части остаются все деньги, а в перенесенной части сумма = 0 р.
Если переносится неоплаченное время, то считается стоимость 1ой части и эта сумма записывается во 2ю часть и "всплывает" при завершении времени .
В примечания обоих частей добавляется "Перенос с № Х (<сумма>)" и "Перенос на № Х" соответственно.

Примечание в Таблице о переносе времени

При переносе еще не наступившего времени оно просто переносится на другой компьютер.

Ненаступившие продленные части времени нужно переносить по-отдельности (из списка времен).

Как это сделать :

  1. Из списка компьютеров - выделите нужный компьютер, щелкните правой кнопкой и выберите пункт меню Перенос "Перенести".
  2. Из списка времен - выделите нужное время, щелкните правой кнопкой и выберите пункт меню Перенос "Перенести".
  3. Из таблицы щелкните правой кнопкой на нужном (см. на "вдавленность") прямоугольнике времени и выберите пункт меню Перенос "Перенести".


Удаление времени

Используется при вводе ошибочных данных.

А) Выберите в списке времен (F4) время, нажмите правую кнопку, выберите пункт "Удалить".

Б) В таблице, щелкните правой кнопкой на нужном (точнее, ненужном) времени, выберите пункт "Удалить".

Если время было текущим, то соответстующий компьютер заблокируется.

В таблице останется "след" на месте удаленного времени.

Здесь удаленное время - серое полупрозрачное.

Нельзя удалить уже закончившееся время и время, по которому уже использовали компьютер больше двух минут.


Дополнительные услуги

Диалог вызывается через меню / Дополнительно / Оформить услугу.

Оформление доп. услуги

При первом запуске программы в списке "Услуга" ничего нет - туда нужно вписать новое название а так же в поле "Стоимость" ввести деньги. После нажатия на кнопку Ок новая название и стоимость запомнится. Это возможно при наличии права "Ввод и изменение цен дополнительных услуг". Если такого права у текущего пользователя нет, то поле "Стоимость" и кнопка удаления услуги будут заблокированы.

Диалог дополнительных услуг с ограниченными правами пользователя сервера

Проверяйте номера чеков !

Если в списке появились ненужные названия, то они удаляются выбором услуги в списке и нажатием на кнопку "Удалить".


Постоплата

Прием денег при пост-оплате

Закончив работу на компьютере, посетитель идет расплачиваться. Администратор выбирает соответствующий компьютер и нажимает Enter в таблице или списке (так же работает двойной щелчек левой кнопкой или выбор конкретного времени с последующим вызовом контекстного меню и выбором пункта "Принять оплату") .

Если у вас есть интернет и ClubControl используется для подсчета трафика, то этот трафик будет посчитан в момент появления диалога (см. в поле "По IP"). Как всегда, можно что-то написать в примечаниях и/или указать скидку. Если посетитель зарегистрирован и имеет персональную скидку или используются АвтоСкидки, то поле ввода скидки будет заблокировано и там будет стоять соответствующая скидка.

При нажатии на кнопку принять время "обрезается" на текущем моменте и если оно было добавлено по умолчанию "до утра", то компьютер будет снова доступен для добавления времени.


Завершение времени

Завершение временни

При необходимости завершить время (с предоплатой) раньше срока (например, клиент ушел) можно это осуществить через пункт меню "Завершить".

Диалог досрочного завершения времени

При установленной галочке "Возврат денег" неиспользованная сумма будет вычтена из общей суммы для возвращения посетителю. В HTML отчетах при наличии в шаблонах соответствующего параметра в итогах будет указана сумма возвратов и в таблице возвратов будет указан каждый возврат отдельно.

Сумма возвратов 9 р.

Возвраты

Комп | Время | Стоимость | Возврат | По прайсу | Тариф | Админ | Прим.
4 | 22:25:23 | 15 | 9 | 9 | game | Administrator |

В графе
Стоимость - указана начальная стоимость времени по прайсу
Возврат - сколько было фактически возвращено
По прайсу - сколько надо было вернуть по прайсу

Завершенному времени будет добавлено примечание "(Возврат (По прайсу $$))" где $$ - начальная стоимость времени.


Изменение тарифа

Если посетитель захотел пересесть с одного тарифа на другой, то можно это сделать из меню Время, пункт "Изменить тариф"

Диалог изменения тарифа

Из списка "Новый тариф" выберите желаемый тариф и нажмите кнопку "Изменить". Если время было добавлено с предоплатой, то исходя из прайса посчитается новая длительность (денежный остаток текущего времени -> новое время). Соответственно, при переходе с дешового тарифа на дорогой время уменьшится, с дорогого на дешевый - увеличится.


Главный вид

Вызывается черех меню / Вид / Список (F4).

Состоит из нескольких частей :

  • Список компьютеров
  • Экран удаленного компьютера
  • Список времен
  • Мониторинг
  • Чат

Список компьютеров

Описание столбцов :

  • № - цифра соответствует условному номеру компьютера.
    Картинка соостоит из корпуса (занятость) и монитора состояние):
    - занят (есть добавленное время прямо сейчас), но выключен.
    - занят, но находится в режиме админа.
    - свободен(прямо сейчас нет оформленного времени) и выключен.
    - свободен и заблокирован (обычная комбинация).
    - свободен и в режиме админа.
    - занят и в режиме Пользователя (обычная комбинация).
    Остальные комбинации "неправильные" и могут появляться на несколько секунд в моменты изменения состояния и т.п.
  • Ост. - Осталось времени до окончания.
  • Режим - Админский, Пользовательский, Заблокированный. У отключенных компов ничего не пишется. Можно спокойно отключить для экономии места.
  • Приложение - последнее запущенное приложение. Если на клиенте включен режим SingleRun, то после закрытия этого приложения удаляется иконка, остается только название. После отсоединения клиента иконка и название стираются.
  • Ночь - Зарезервированная на сегодня ночь рисуется [image].
  • Версия - номер сборки клиента (используется для обновлений ичем больше, тем лучше:).
  • Конец - время окончания текущего сеанса.
  • Осв. в - (освободится в) - время освобождения компьютера, учитываются продления и резервирования времени. В это время компьютер точно будет свободен до конца смены.
  • До осв. - (до освобождения) - сколько времени осталось до полного освобождения компьютера.

Контекстное меню заголовка списка времен Контекстное меню заголовка списка компьютеров Щелкнув правой кнопкой мыши по заголовку колонки, можно быстро спрятать ненужные или показать спрятанные.

Операции

Компьютеры выделяются спомощью мыши и /или кнопок Ctrl, Shift, Space, Arrows. Ctrl + A выделяет все компьютеры.С выделенными компьютерами можно взаимодействовать с помощью меню / клиент или контекстного меню по правой кнопке мыши. Большую практическую ценность представляет сортировка (по убыванию) - по щелчку левой кнопкой на заголовке списка. Можно быстро определить ближайшие свободные компьютеры, отсортировав список по времени.

Двойной щелчек мышью или нажатие Enter выполняет автоматическое действие : Если выбран ОДИН компьютер и у него сейчас идет время БЕЗ ПРЕДОПЛАТЫ, то вызовется диалог завершения времени (для того, что бы принять деньги). В противном случае вызовется диалог Добавление времени - для посадки новых пользователей.

Экран удаленного компьютера

Экран удаленного компьютера

Из контекстного меню (вызываемого нажатием правой кнопки мыши) доступны действия

  • Обновить - запрос текущеей картинки.
  • Полный экран - показать картинку во весь экран.
  • Настройки -

Свойства снимка экрана

Качество - определяет уровень сжатия изображения и нагрузку на сеть. При редком использовании этой функции и быстрой сети можно ставить максимальное.
Приоритет (создания картинки клиентским компьютером относительно других программ) - отправка картинки при работе ресурсоемких игр может "затормозить" компьютер на пару секунд. При понижении приоритета (LOW<-) этого не будет заметно, но зато изображение может создаваться долго.
Обновлять при выделении компьютера - при выделении компьютера в списке компьютеров будет автоматически запрошено изображение с его экрана.
Обновлять каждые Х секунд - изображение будет обновляться непрерывно с заданным интервалом.

Список времен

При изменении выделения в списке компьютеров список времен заполняется оформленными записями по выбранным компьютерам, причем текущее время выделяется. Отображаются данные за текущую смену - в обычном режиме и все загруженные - в режиме просмотра.
Возможна сортировка по убыванию.Выделнные строки идут в выборочный отчет.

Операции

выполняются из меню / Время или из контекстного меню.

Операции со временем

Пункт "Пересчитать трафик" нужен только при использовании анализатора лог-файлов в очень редких случаях. Вам он не нужен.
 "Завершить" обрезает время - если посетитель ушел раньше. По остальным действия см. Добавление, Продление, Перенос, Удаление, Завершение, Изменение тарифа .

Мониторинг

Окна удаленного компьютера

Соединения TCP на удаленном компьютере

При изменении выделения в списоке компьютеров выделяемым компьютерам посылается запрос на перечень процессов, окон и соединений, после чего клиент отсылает эти данные. Нажав правую кнопку мыши или кнопку контекстного меню на клавиатуре, можно вызвать меню. Пункт "Обновить" сотрет имеющиеся данные только для текущего раздела (Процессы/Окна/Соединния) и запросит их опять. Пункт "Убить" завершит процесс/соединение/закроет окно/ и тут же пошлет запрос на обновление. Параметр Автообновление - будет ли отослан запрос на обновление данных клиенту при выделении компьютеров в списке.

Рядом (сверху) со списком процессов показывается количество свободной оперативной памяти и свободное место на жестких дисках клиента (диск можно выбрать из списка посередине) . Эти данные всегда обновляются при выделении компьютера.

Чат

Для отправки сообщения ВЫДЕЛЕННЫМ компьютерам введите текст в нижней строке и нажмте кнопку "Отправить". При нажатии Ctrl+Enter сообщение клиенту посылается как Быстрое сообщение . Можно вручную добавлять флаги. Например "Это текст в окошке/B". Если флаг не указан, то сообщение считается текстом красного на прозрачном фоне.
Очистить накопившиеся сообщения можно и контекстного меню, появляющегося при нажатии правой кнопки мыши на окошке с сообщениями.

При подключении через "Сеть ClubControl" (сервер к серверу) при отсутствии выделенных компьютеров сообщение отправляется всем подключенным серверам.

Экран удаленного компьютера

Название говорит само за себя. При большом количестве компьютеров можно убрать его с экрана, перетащив окошко вниз за верхний край. По щелчку правой кнопкой мыши появляется контекстное меню. Пункт Обновить запрашивает новый скриншот у выделенного клиента.

Свойства кортинки Настройки :
Качество сжатия JPEG - Влияет на размер передаваемой по сети картинки, не влияет на загрузку клиента.
Приоритет (IDLE, LOWEST, NORMAL, HIGHEST) - как быстро клиентский компьютер сгенерирует картинку, чем выше, тем быстрее, соответственно при этом запущенные игры могут больше притормаживать. IDLE - картинка создастся, только когда процессор клиента будет полностью свободен.
При выделении компьютера в списке картинка может автоматически запрашиваться. Старая стирается сразу.
Можно выбрать постоянное обновление по таймеру в секундах.

Если испортился внешний вид - например пропали какие-то окна, то можно удалить из реестра windows ветвь HKEY_CURRENT_USER\Software\ClubControl\3.0\Interface.


Таблица

Графическая Таблица

Позволяет одним взглядом оценить текущее (или за любой период) состояние клуба. Основными параметрами являются оформленное время и реальная занятость компьютеров. В идеале эти два параметра должны совпадать, что означает что компьютеры работают строго официально.

Вызавается через меню / Вид / Таблица (F3).

Структура таблицы

Почти пустая таблица

.Горизонтальные линии соответствуют компьютерам, вертикальные - вриемени (черные линии - часовые, серые - 15 мин.). При данных настройках фон отображает время суток - светло-зеленый=день, темно-зеленый=ночь. В рабочем режиме показаны 24 часа от начала смены. Можно загрузить несколько файлов :

Выделение компьютеров осуществляется левой кнопкой мыши : щелчек на выделенном компьютере снимает выделение, на не выделенном - выделяет его. При удержании кнопки Ctrl щелчек левой кнопкой мыши инвертирует выделение одного компьютера, не меняя остальных. Средняя кнопка мыши снимает выделение со всех компов, Ctrl + A выделяет все.

Цвета полностью настраиваются из пункта меню, вызываемого нажатием правой кнопки мыши на таблице. Контекстное меню

Примечание: Первое меню разделено по коризонтали чертой : Верхние пункты (Перенести, Продлить и Удалить) относятся к конкретному времени, которое надо выделять движеним мыши по вертикали (компьютер) и по ГОРИЗОНТАЛИ (время этого компьютера).

Меню выделения времени Выделение: Времена в могут выделяться (диагональной решеткой) по следующим параметрам :

Выделенное время Текущее время - время, пересекаемое вертикальной красной чертой.
0 денег - это могут быть куски переносов, халявщики, 100 % скидки и т.п.
Незакрытое время - неоплаченное (не отмечнное админом) время без предоплаты.
Ночь - время, начало и конец которого совпадает с ночным интервалом в настройках.
Есть трафик - интернет трафик больше 0 байт.
Изменен тариф - время пользователей, которым меняли тариф "на лету".

Оформленное время в таблице рисуется в виде большого прямоугольника (высотой в 1 полосу Еденица времени компьютера) и шириной , соответствующей длительности. При разрешении монитора 800*600 и развернутой на весь экран программе один пиксель соответствует ~2 минутам. На картинке - 1 час, Если ширина (длительность) достаточна, то пишется сверху - номер чека и снизу - деньги.

Подробности При наведении курсора время "вдавливается" и в плавающей подсказке показывается более подробная информация :

Пусто... При перемещении мыши по пустому месту просто показывается соответствующая дата и № компьютера.

Текущее время Текущее время (вертикальная красная полоска) рисуется другим цветом .

Состояния

Через определенный интервал времени (по умолчанию 5 мин.) каждый клиент посылает по сети серверу сигнал, в каком он состоянии (Админ, Пользователь, Заблокирован).
Эти сигналы сохраняются в файле сс2 и заносятся в таблицу в виде маленьких точек.В зависимости от частоты отсылки этих состояний они могут рисоваться так Увеличенный админский период

или так : Опят админ ! !

Исходя из приведенных выше настроек цветов :

Заблокировано - Заблокированный режим

Админ - Режим админа

Пользователь - Режим пользователя

Следует заметить, что выбранная комбинация не совсем удачна : цвет состояния пользователя сливается с цветом фона...

Что же можно из всего этого заключить

  1. Состояния пользователей [image] должны быть закрыты оформленным временем ! Кто-то посидел нахаляву !
    На картинке - 4 часа кто-то сидел просто так ! (Маленькая зеленая полоска - есть, а оформленного времени - нет !!!). Вот как это должно выглядеть : Как надо : (Пользователь сидел "в оплаченном времени").
  2. Не должно быть злоупотреблений админским режимом, т.е таких последовательностей : Опять админ ! .

И, для примера, образцово-показательная таблица :

Вот как надо !


Клубные карты

Клубная карта это определенное количество времени по определенному тарифу. Клиент с картой может использовать ее в любое время не зависимо от общих цен.

Работа с клубными картами разделяется на две части : Продажа и "Посадка" клиента с КК.

Список КК находится в разделе "Пользователи" (закладка "Клубные Карты"). Отсюда доступны основные операции с ними : продажа, удаление, определение номиналов.

Раздел клубных карт

В колонке "Регистрационное имя" присутствует значек [image], если найдена фотография посетителя. Щелкнув по нему мышью, можно посмотреть фото в полный размер.

Для быстрого поиска карт можно ввести в поле "Поиск по имени" или "Поиск по номеру" часть имени или номера - будут выделены все подходящие карты.

Продажа

Кнопка "Добавить...".

Как продать КК

При вводе номера в поле №

  • если введен новый №, то появляется возможность ввести Имя (необязательно), чек (ввести или проверить) и выбрать номинал карты, после чего включится кнопка "Добавить". Можно загрузить фотографию посетителя, нажав на кнопку "Загрузить". При этом в окошке появится (возможно уменьшенная) фотография.
    После добавления карты с фотографией картинка (jpg) будет скопирована в папку Photos под названием <имя пользователя>.jpg. С файлами картинок можно производить любые действия - удалять, редактировать и т.д.

  • если введен существующий №, то показывается информация по карте (на рис.)

Когда приходит посетитель с КК, он сообщает администратору № своей карты, и администратор вводит этот номер при Добавлении времени

Удаление

Выделите одну или несколько карт, которые нужно удалить и нажмите кнопку "Удалить...". Перед удалением каждой карты будет запрошено подтверждение. Фотографии при этом не удаляются.

Как ввести номиналы КК

В файле CC.INI в конце добавьте раздел [ClubCards] (с квадратными скобками). Каждая последующая строчка в формате <тариф> <номинал(в мин.)> = <стоимость(в руб.)> будет соответствоовать одному типу карты.

Пример :
[ClubCards]
internet 600=250
internet 1200=400
game 600=100

- определены 3 номинала - интернет 10 часов за 250 р. и 20 часов за 400 р. и игры 10ч / 100р

Как включить компьютер клиенту по КК

Надо при обычном добавлении времени (например, выделить компьютер(ы) и нажать Enter) просто ввести номер карты в поле "Клубная карта". Если у карты есть фотография, то при вводе номера справа выдвинется окошко с уменьшенной копией фотографии.

При этом в поле Длительность будет введено оставшееся до конца смены (но не большее остатка на карте) время, которое будет вычтено из карты. Трафик (если у тарифа включен интернет) будет неограничен. При завершении этого времени на карту будет возвращен остаток. Можно уменьшить это время (например, клиент хочет отсидеть ровно час из карты), тогда лимит трафика будет посчитан обычным методом из прайса.

При посадке нескольких клиентов по одной карте одновременно из карты вычтется суммарное время.


Заказы (резервирование времени)

Существуют три вида предварительного заказа времени :

  • Предварительная продажа
  • Быстрое резервирование ночи
  • Заказы

Предварительная продажа

Время продается в обычном режиме, при этом просто ставится нужная дата начала сеанса. Компьютер автоматически разблокируется в указанный момент. Деньги за проданное на будущие смены время отображаются в текущем отчете как обычно, и в отчете за тот день, когда начнется этот сеанс в виде "неучтенного времени".

Быстрое резервирование ночи

Вызывается из меню Время / Ночь / Пометить (Ctrl+Shift+N)

Быстрое резервирование ночи

При нажатии на кнопку "Заказать" выбранные компьютеры помечаются в колонке "Ночь" списка компьютеров. Там указано время (ЧЧ:ММ) до начала ночи (до того времени, которое было поставлено в диалоге в поле "Действительно до". Эта пометка носит рекомендательный характер и не мешает обычному добавлению времени. В таблице никаких изменений при этом не происходит. При добавлении ночи в колонке "Ночь" вместо оставшегося времени рисуется значек ночи.

Данную функцию можно применять для примерного определения количества желающих посидеть в заведении ночью, без каких-либо обязательств с их стороны.

Заказы

Предварительную продажу времени можно осуществлять, используя систему заказов. Она позволяет брать предоплату в виде процентов от стоимости заказа или фиксированной ставки, использовать Персональные и Автоматические скидки постоянных клиентов.

Отличие заказанного времени от обычного проданного заключается в том, что до полной (100%) оплаты заказа клиентский компьютер не разблокируется, а предоплата за заказы не входит в общую кассу и при отмене заказа (и возврате предоплаты) не нужно писать заявление.

Работа с заказами производится из вида "Заказы" (F2). Выделите нужные компьютеры и нажмите Enter (если компьютер один, можно на нем два раза щелкнуть мышью).

Предварительный заказ времени

В появившемся диалоге нужно ввести длительность. При необходимости изменить дату, время, выбрать тариф, предоплату. Предоплату можно определять, вводя проценты или прямо сумму. Если вы ввели проценты, то эта цифра запомнится и в следующий раз ее можно будет выбрать из списка.

Можно ввести имя пользователя в соответствующее окошко. Если такой пользователь зарегистрирован, то кнопка "фотография" (для простомотра фото клиента) станет доступной и в поле "Скидка" будет введена скидка пользователя (если у ему назначена Персональная скидка - то она, или же Автоматическая).

Предоплата за оформленный заказ вносится в банк предоплаты, общая сумма в котором показывается в строке "Денег за неподтвержденные заказы". В финансовых отчетах предоплата не отображается (только вся стоимость после окончательной доплаты).

В списке заказов показываются заказы на дату, введенную в поле "Заказы на".
С помощью строки поиска можно быстро выделить заказы по имени пользователя.

Список заказов :

  • Имя - имя посетителя.
  • Предоплата - сумма внесенной при оформлении предоплаты.
  • Предоплата (дата) - дата и время оформления заказа (внесения предоплаты).
  • Доплата - сумма доплаты. Колонка пустая, если доплата не была произведена.
  • Доплата (дата) - дата и время доплаты. Колонка пустая, если доплата не была произведена.
  • Возврат - сумма возврата при отмене заказа. Колонка пустая, если отмена не была произведена.
  • Возврат (дата) - дата и время отмены заказа. Колонка пустая, если отмена не была произведена.
  • Начало - дата и время начала сеанса.
  • Длительность - длительность сеанса.

Выбрав заказы, нажмитеправой кнопкой мыши для вызова контекстного меню со следующими пунктами :

  • Подтвердить (то же самое = двойной щелчек мыши) - принятие доплаты. После этого время перестает быть заказом и превращается в обычное проданное время, клиентский компьютер сам разблокируется в нужный момент.
  • Отменить - отмена заказа по желанию посетителя с возвратом предоплаты. Так как деньги возвращаются не из кассы, тио в финансовые отчеты запись о возврате не идет, однако запись о заказе с датой и суммой возврата сохраняется. В таблице (F3) и в отчетах время удаляется бесследно.
  • Удалить - полное удаление заказа из таблицы заказов. В таблице (F3) и в отчетах остается удаленное время.
  • Показать время - вид переключается на "Список" (F4) и выделяются соответствующии заказу компьютеры и время.


Статистика

Статистика - Игры

Один столбец соответствует одной программе (точнее, одному уникальному названию ярлыка). При небольшом количестве программ показываются их названия.Цифра сверху каждого столбца - значение параметра из списка "Высота", по умолчанию и на рисунке - количество запусков программы. Существуют параметры :

  • Запуски - количество запусков программы.
  • Рейтинг - сколько раз посетители голосовали за эту программу.
  • Первая дата - когда программа была запущенна в первый раз - (Как давно в нее играют).
  • Последняя дата - когда программа была запущенна в последний (ближайший) раз - (Может ее уже год никто не трогает ?).
  • Длительность - сколько времени всего проведено в программе (Может быть ее запускают и через пять минут выключают - имеет смысл для новых прграмм).
  • Название - по алфавиту.

Сортировка по параметрам меняет расположение столбцов (но не их высоту!).

Цвет каждого столбца определяется по параметру "Цвет" - чем больше значение выбранного параметра, тем дальше цвет от начального (на рис. - зеленый) и ближе к конечному (синий).

Кнопка "Их пожелания" показывает пожелания посетителей "в свободной форме". (Можно стирать файл "User Opinions.txt", где это лежит, или редактировать прямо из появившегося Блокнота.

Статистику можно "сбросить" , удалив файл GameStats.dat.

Удалить отдельные записи или объеденить вместе несколько (например если обнаружилась одна игра под разными именами) можно из контекстного меню, вызываемого нажатием правой кнопки мыши на нужном столбце статистики. При объединениии данных имеет значение регистр названия.

Соответствие названий программ реальным файлам задается в файле Shortcuts.txt на клиентах (в папке установки, по умолчанию C:\CCC).

Статистика - Клуб

На момент написания справки для просмотра статистики за период нужно загрузить соответсвующие файлы из меню Файл/Открыть.

Отображаемая информация :
Точный - абсолютная загруженность клуба с точностью до пикселя.
Почасовой - загруженность в процентах на каждый час из 24. 100% соответствует полной занятости часа в течение ВСЕГО периода.
Дни недели, Месяцы - распределение занятости по дням и месяцас соотв.
Тарифы - отношение временной занятости и дохода со всех тарифов, присутствующих в загруженном периоде.

Можно отсечь информацию по конкретному тарифу, выбрав его в списке Тариф.


Управление компьютерами

Осуществляется из меню / Клиент или из контекстного меню Списка компьютеров.

Команды отправляются выбранным в таблице/списке компьютерам.

  • Послать сообщение - Быстрое сообщение.
  • Ярлыки - Показывает список установленных на клиенте игр. Для одного компьютера. При нажатии программа запускается.

Что там у нас ?

  • Режим - установка другого режима. При переходе в "неправильный" (наприметр , у клиента есть время , а его заблокировали)режим клиент в течение 5 секунд перейдет в "правильный" (в прведенном примере - в режим пользователя). НО Админский режим никогда не выключается (т.е. не меняется на другой) автоматически ! - наиболее целесообразно использовать это меню для ВЫКЛЮЧЕНИЯ (включения) Админского режима.

Все 3 состояния

  • Поменять пароль - Пароль на включение Админского режима на клиенте локально. В зависимости от настроек, может понадобится знание текущего пароля (в этом случае появляется приписка "(всем)" и пароль меняется всем клиентам одновременно не зависимо от того, какие компьютеры выделены. Если некоторые клиенты отключены, то на них пароль поменяется после подключения к серверу.
  • Посадить
  • Продлить
  • Перенести
  • Наказать - Оставшееся Время уменьшается на выбранное кол-во минут, в примечания добавляется "Наказан на ХХ мин.".

Как их наказать...

  • Взглянуть на экран - просмотр содержимого экрана, выход по левой кнопке. См. Наблюдение.
  • Проводник - Запуск Windows Explorer с просмотром компьютера по сети (при наличии MS File and Print Sharing)
  • Настройки - изменение/просмотр различныых параметров клиентских компьютеров.

  • Запустить - запуск (программы) на клиенте. Действительно для одного компьютера. Если стоит галочка "Сохранять в списке", то запущенная программа запомнится и ее можно будет быстро выбрать из выпадающего списка, а не вводить вручную при последующих обращениях.

  • Закрыть игру - Убивает запущенную под SingleRun программу.
  • Питание - стандартный набор, несохраненные данные пропадают.

  • Монитор - ручное включение/выключение режима энергосбережения монитора. Уровень энергосбережения определяется в настройках, раздел "Монитор".
  • Запущенная программа - Заморозить/Разморозить - Принудительная пауза для программы при SingleRun.
  • Выйти из ClubControlClient'a - Выключает ClubControlClient и запускает Windows Explorer без изменения оболочки (shell'a).
  • Мышь для левши / правши - меняются местами крайние кнопки.
  • Мышь и клавиатура - заблокировать / разблокировать - Соответствует названию, локально можно разблокировать по Alt-Ctrl-Del.
  • Звук - управление громкостью звука (общая громкость).

  • Файлы игроков - копирование файлов (сохранений игр, или героев, или любых других) по заранее определенному шаблону. См. Копирование сохраненных данных.

Копирование файлов (сейвов) по шаблону

  • Разрешить окна Открыть/Сохранить - если в настройках запрещены стандартные окна отркрытия/сохранения файлов, то этот пункт меню временно (до перезагрузки или окончания сеанса) отменяет запрет. Это можно делать например известным надежным посетителям.
  • Послать новую версию - из папки автообновления будут отосланы файлы.
  • Запросить информацию - обновить всю информацию в окне мониторинга (процессы, окна, соединения, место на дисках).


Traffic

Интернет трафик

С помощью ClubControl можно предоставлять доступ в интернет (или к другим сетевым ресурсам) на основе платы за время, проведенное в интернете и/или количества потраченного трафика. Так же есть возможность ограничения максимальной скорости интернета для каждого клиентского компьютера.

Существуют два варианта настройки программы для работы с интернетом :

  1. Снифер +файрвол TCP.
  2. Встроенный в клиентскую часть прокси-сервер.

Снифер является универсальным решением для подсчета трафика, рекомендуем использовать именно первый вариант. Плюсом является то, что можно запрещать доступ к отдельным сайтам (сетевым ресурсам) в зависимости от оплаченного посетителем тарифа или, наоборот, предоставлять доступ к чему-либо бесплатно (например, к локальным сайтам, трафик с которых бесплатен). Минусом является необходимость применения внешних средств для блокировки UDP трафика (firewalls).
Если в вашем клубе для раздачи интернета на клиентские машины используется прокси сервер (например WinGate, WinProxy, UserGate) и по интернету нельзя играть, то используйте второй вариант. Плюсом является возможность ограничения скорости интернета для конкретных компьютеров.

Наличие (разрешение использования, стоимость трафика и т.д.) интернета определяется в прайсах для каждого тарифа.


Снифер

Снифер это универсальная система подсчета трафика. Можно учитывать абсолютно весь трафик (например, в играх) и при любых сетевых конфигурациях. Подсчет производится на уровне сетевой карты, вся настройка сводится к составлению "фильтра" - условного выражения - который определяет, какой трафик, проходящий через сетевую карту, считать, а какой - нет.

Настройки для подсчета трафика

Для включения снифера нужно

  1. Выключить встроенный прокси (Снять галочку "Использовать встроенный прокси").
  2. Выбрать сетевую карту из списка "Адаптер" для каждого клиента.
  3. Задать фильтр.
    Трафик считается с помощю сетевой карты, а через нее обычно проходит как локальный, так и интернет-трафик. Фильтр нужен для определения того, что считать, а что - нет. Для большинства конфигураций сети клуба подойдет фильтр по умолчанию - "(proto TCP or proto UDP) and not src net 192.168" - будет учитываться трафик не исходящий с адресов 192.168.Х.Х. Для опытных системных администраторов прилагается файл с описанием настроек фильтра ("BPF Filter Format.txt").

Сообщать на сервер трафик при изменении на Х Кб - как только клиент закачал очередную порцию трафика размером Х Кб, то на сервер будет отправлена информация об этом. В списке сеансов, если выделен соответствующий компьютер, будет показано новое количество закачанного трафика и в базу данных так же будет записана обновленная информация. Увеличение размера порции может понадобится при быстром интернет-соединении, когда его скорость приближается к скорости локальной сети - если все клиенты интенсивно используют интернет и тут же "отчитываются" серверу, может возникнуть замедление скорости работы сети или программы.

Снифер только считает трафик. При его использовании для ограничения нужно настроить firewall .


Снифер

Firewall

Для управления доступом к любым сетевым ресурсам (интернет, другие компьютеры) в клиентов встроен firewall (фв). Он позволяет запретить/разрешить доступ к IP-адресам и/или портам в зависимости от тарифа.

Настройки фв хранятся в фалйах конфигурации с расширением .fw.cfg в папке установки клиента.

При добавлении времени с разрешенным интернетом клиент загружает конфигурацию из файла <название текущего тарифа>.fw.cfg. Например, при добавлении времени по тарифу "game" загружается "game.fw.cfg". Эти файлы необязательны, они могут пригодится только для ограничения доступа к конкретным сайтам в определенных тарифах.
Если же интернет запрещен, или кончился трафик то независимо от тарифа загружается файл Locked.fw.cfg. В нем должно быть определено, что разрешать, а что запрещать при отсутствии доступа к интернету. Т.е. должна быть разрешена только локальная сеть (если конечно он нужна) и сам ClubControl (порт 7699 по умолчанию).

Структура файла :

[Restricted Addresses]
<пара адресов (х.х.х.х-х.х.х.х)>
<пара адресов (х.х.х.х-х.х.х.х)>
...
<пара адресов (х.х.х.х-х.х.х.х)>

[Restricted Ports]
<пара портов (х-х)>
<пара портов (х-х)>
...
<пара портов (х-х)>

[Allowed Addresses]
<пара адресов (х.х.х.х-х.х.х.х)>
<пара адресов (х.х.х.х-х.х.х.х)>
...
<пара адресов (х.х.х.х-х.х.х.х)>

[Allowed Ports]
<пара портов (х-х)>
<пара портов (х-х)>
...
<пара портов (х-х)>

[All Other]
<Что делать со всеми остальными соединениями (не указанными выше) Allow=1 или Allow=0>

Для указания одного адреса/порта используется пара Y=Y где Y - адрес или порт (напр. 192.168.1.1-192.168.1.1). Порядок просмотра : [Restricted Addresses][Restricted Ports][Allowed Ports][Allowed Addresses].Т.е. приоритет больше у разрешающих записей. Если [All Other] Allow=0 и адрес не найден выше, то соединение закрывается.

В файле firewall.rar находятся два файла примеров для тарифов game и internet. В тарифе game запрещены все сетевые соединения, кроме некоторых портов и сети 192.168.*.*.

Пример :

1) Файл Internet.fw.cfg определяет, что при наличии трафика в тарифе "Internet" запрещен доступ к сайту с IP-адресом 217.16.18.35.
Адрес сайта можно узнать по его имени с помощью команды ping <имя сайта>.

[Restricted Addresses]
217.16.18.35-217.16.18.35

[Restricted Ports]

[Allowed Addresses]

[Allowed Ports]

[All Other]
Allow=1

2) Файл Locked.fw.cfg - в нем запрещено все адреса (0.0.0.0-255.255.255.255), все порты (0-65535), но оставлены открытыми локальная сеть (192.168.0.1-192.168.0.100,139-139) и СС (7699-7699).

[Restricted Addresses]
0.0.0.0-255.255.255.255

[Restricted Ports]
0-65535

[Allowed Addresses]
192.168.0.1-192.168.0.100

[Allowed Ports]
7699-7699
139-139

[All Other]
Allow=0

Файрвол только отключает трафик. При его использовании для подсчета нужно настроить Снифер .


Прокси-сервер

В клиентов встроен прокси сервер для управления интернетом. Для того, что-бы система работала, необходимо в настройках браузера указать в разделе прокси-сервер адрес localhost (или 127.0.0.1) и порт , вписанный в параметре "Порт прокси ССС" для ВСЕХ протоколов (http, ftp и т.д.).

Настройки Internet Explorer

В настроках прокси ClubControl вписать адрес и порт прокси-сервера делящего интернет в клубе или провайдерского.

Интернет включается при посадке по тарифу "internet" или "интернет".

Параметр "Лимит трафика" позволяет ограничивать входящий трафик, абсолютное доступное количество трафика показывается на клиенте в нижнем левом углу (2047 кб на картинке). Значение 0 = нет ограничений. Трафик можно добавлять с сервера (в т.ч. за отдельную плату).

!С помощью задержки можно незаметно для пользователя ограничить скорость интернета (а значит и трафик) без всяких внезапных отключений .


Анализатор трафика

Анализатор лог-файлов внешних прокси-серверов

Предназначен для подсчета объема трафика, прошедшего через компьютеры, подключенные к интернету через внешний прокси-сервер и сопоставления этих данных с финансовой статистикой.

Внимание ! Эта система не нужна для обычной работы ClubControl с интернет трафиком (подсчет, блокировка) а является только вспомогательным инструментом. Если вы не знаете, зачем могут панадобиться лог файлы прокси сервера, то не читайте этот раздел.

Вызывается из меню Дополнительно/Трафик. После указания периода и нажатия кнопки "Посчитать" будут показаны результаты.

Настройки :

Настройки для старого подсчета трафика

Если Ваш прокси-сервер есть в списке "Программа (прокси)", то выбирайте заданные настройки, или вручную задавайте параметры.

В меню "Время" пункт "Пересчитать трафик" : Программа проанализирует лог-файл и для выделенных времен запишет соответствующий трафик + покажет общую сумму.
При включенном автоматическом пересчете это будет проводиться при окончании времени (но нужно, что-бы в этот момент сервер был включен). Эти данные заносятся в таблицу и отчеты.
Анализатор трафика показывает, сколько интернета использовалось посетителями в течение оплаченного времени, в другое время, другими компьютерами (администраторами). Количество оплаченного трафика расчитывается на основе данных в таблице (если нужно просмотреть лог-файлы за период, загрузите также и файлы сс2/сс3 соответствующие периоду для правильного отображения оплаченного/неоплаченного трафика). Список сетевых адресов заполняется из лог-файла по мере его анализа.

Разные программы создают "логи" в разных форматах, поэтому существуют 3 основных параметра (все в разделе [ClubControl]):

  1. Имя лог-файла. Может быть только один файл или за каждый день отдельный. Если файл один (WinRoute, WinGate4.3), то в параметр LogFile указывается имя файла без пути. Если файлов много (на каждый день свой), то параметр LogFile нужно оставить пустым.
    Параметр LogFolder - папка с лог-файлами.
    Напр. LogFolder=c:\wingate\logs\
    LogFile=WWW Proxy server.log
  2. Параметр LogCreator - на момент написания 3 варианта (без кавычек): "WinGate","WinRoute","WinGate43".
  3. Формат данных.
    WinGate - LogTemplate=%2s/%2s/%2s %2s:%2s:%2s %s %*s %*s Traffic %*i %*i %*i %i %*is
    WinRoute - LogTemplate=%15s - - [%2s/%3s/%i:%2s:%2s:%2s %*[+-]%*4s] "GET %*s HTTP/%*i.%*i" %*i %i


Наблюдение за компьютерами

В ClubControl cуществуют 3 способа посмотреть на экран клиентского компьютера (в формате JPEG), не сходя с места :

  1. Из списока компьютеров выбрать пункт меню Клиент - "Взглянуть на экран". В зависимости от скорости сети и компьютеров, сразу или через несколько секунд у вас на экране "в полный рост" будет показано содержимое удаленного экрана. Что-бы убрать это окошко, щелкните по нему левой кнопкой мыши. Качество / размер такой картинки определяется параметром в файле CC.INI : раздел [Visual Control Center], параметр FullScreenQuality, значение от 0 до 100 (чем больше, тем лучше).
  2. Переключиться на вид "Визуальный контроль" (F6) и щелкнуть правой кнопкой мыши на окошке, соответствующем нужному компьютеру - Появится тот-же полноэкранный снимок. их много...
    Нажатие Пробела запросит одиночные маленькие картинки у ВСЕХ компьютеров.
  3. Можно получать не отдельный "скриншотик", а непрерывный их поток , щелкнув левой кнопкой.

Зеленый квадрат в углу каждого окошка означает , что потоковая передача изображения отключена. При включении он пропадает и не его месте может появиться цифра, показывающая время, затраченное на взятие скриншота на УДАЛЕННОМ компьютере . Ее можно отключить из файла cc.ini - раздел [Visual Control Center] , параметр ShowInfo, значение 1 = показывать, 0 - нет.

Получаемые картинки сохраняются в формате JPG в основной директории программы, если в ини-файле в разделе [Visual Control Center] параметр SaveScreenshots равен 1.

Параметр ComputersInLine , равный 4 по умолчанию, определяет размещение компьютерных окошек.

Параметр StreamQuality задает качество маленьких картинок.


Копирование сохраненных данных

Это мощный инструмент с широким спектром применения : в простейшем случае можно использовать для быстрого копирования "сейвов" или "героев" с компьютера пользователя на дискету (на серверном компьютере) и обратно, или с компьютера на компьютер. Можно копировать не только игровые файлы, а вообще любые. Это может пригодиться, когда периодически нужно копировать куда-то файлы из определенных папок и/или файлы по определенной маске.

Меню Клиент - Дополнительно - Файлы Игроков.

Копирование файлов (сейвов, героев)

Использование

а) Копирование с компьютера на компьютер или на дискету (на серверном компьютере).

  1. Выделите компьютер, с которого нужно скопировать файлы на другой компьютер.
  2. Вызовите диалог копирования (например, нажав Ctrl+Shift+S).
  3. Выберите нужную игру в списке "Игра". При этом список "Имя" будет заполнен подходящими по шаблону названиями.
  4. Введите или выберите из списка "Имя" имя игрока.
  5. Выберите, куда копировать файлы.
  6. Нажмите кнопку "Копировать".

б) Копирование с дискеты (на серверном компьютере) на клиентский компьютер.

  1. Выделите компьютер, на который нужно скопировать файлы с дискеты.
  2. Вызовите диалог копирования (например, нажав Ctrl+Shift+S).
  3. Установите переключатель "С дискеты (А:)". При этом список "Имя" будет заполнен подходящими по шаблону названиями.
  4. Выберите нужную игру в списке "Игра".
  5. Введите или выберите из списка "Имя" имя игрока.
  6. Нажмите кнопку "Копировать".

Принцип действия

По заранее определенному шаблону, выбираемому из списка "Игра", имени и номеров компьютеров составляется сетевой путь. При нажатии кнопки копирования файлы, попадающие под маску в шаблоне, копируются в место назначения.
После выбора названия из списка "Игра" список "Имя" заполняется подходящими по маске названиями файлов, при этом происходит подсчет размера папки вместе со всем ее содержимым. В это время "лампочка" (зеленая на рисунке выше) красная, но завершения процесса можно и не дожидаться. При вводе имени будет показан размер соответствующих ему файлов.

Настройка

Файл cc.ini раздел [Game Saves]
<название игры>=<путь к файлу или папке>
В пути могут использоваться маcки (*)
"<name>" заменяется на введенное имя игрока
"<comp>" заменяется на IP-адрес компьютера (откуда или куда копировать). IP берется из файла "IP.cache"

Например :

[Game Saves]
Diablo II=\\<comp>\Games\Diablo II Shareware\Save\<name>.*
Operation Flashpoint=\\<comp>\c\Games\OperationFlashpoint\Users\<name>

При выбраном компьютере №3 и введенном имени SuperKiller \\<comp>\Games\Diablo II Shareware\Save\<name>.* заменится на \\192.168.0.3\Games\Diablo II Shareware\Save\SuperKiller.*


Быстрые сообщения

Отсюда они отправляются в...

Быстрые сообщения так названы, потому что для отправки требуется 2 щелчка мыши . Находятся в меню / Клиент / "Быстрые сообщения" или в контекстном меню списка компьютеров. При нажатии на сообщение оно отправляется выделенным в списке/таблице компьютерам. Пункт "Редактировать" позволяет добавить,удалить или изменить сообщения.

Здесь сообщения показаны вместе с форматом ( в конце, начинается с "/"). Формат описан в ини-файле.При выделении сообщения становятся доступными кнопки "Удалить" и "Свойства". Двойной щелчек левой кнопкой мыши равнозначен нажатию кнопки "Свойства". Один щелчек - редактирование сообщение прямо на месте, подтверждение изменений - Enter.

Доступны 4 типа сообщений :
Свойства сообщения

  1. Текст - указывается длительность в секундах. В течение этого времени сообщение будет рисоваться на экране. Приоритет определяет, как сильно будет тормозить клиентский компьютер во время отрисовки сообщения / как четко будет оно выводться. Приоритет HIGHEST - страшное наказание для нерадивого игрока...
    Сверху

    То-же
  2. WAV - файл - при выборе этого типа появится стандартное окошко для указания пути к этому файлу. При отсылке сообщения файл читается и данные отправляются клиентам ...
  3. Табличка - самая обычнач windows табличка.
  4. Голос - при установленном НА КЛИЕНТЕ SAPI 5.0> будет синтезироваться речь. SAPI требуемой версии поставляется с WindowsXP. Отдельно на любые Windows можно получить [на момент написания - по запросу] у нас на сайте (~3 Mb).

Кнопка "Просмотр" - сообщение проигывается на этом же компьютере - можно сразу увидеть, как оно будет выглядеть.

В файле CC.INI они хранятся в разделе [Quick Messages]. По аналогии с имеющимися там сообщениями можно настроить вид автоматического сообщения о том , что осталось мало времени или закрывается клуб...


Сеть ClubControl

Одной из многочисленных уникальных особенностей программы ClubControl является возможность просмотра информации по клубу по сети (Локальной или Интернет) .

Вы можете посмотреть, что происходит в клубе подключившись к работающему серверу из другого помещения или даже из дома по Интернету или установив модемную связь.

Как подключиться

Запускайте сервер и выбирайте в меню Дополнительно / Сеть ClubControl / Подключиться.

Готовимся к подключению

Далее указываете адрес сервера, к которому будете подключаться (IP или dns), порт (по умолчанию 7698) и жмете кнопку "Подключиться". В верхнем окошке появится надпись "Connecting..." с отсчетом времени с начала попытки соединения и через несколько секунд - результат.

При успешном подключении будет запрошен пароль. Нужно ввесть главный пароль удаленного сервера (меняется в настройках F10). После ввода правильного пароля статус изменится на "Connected.".

После подключения

Теперь доступны две кнопки :
"Запросить финансовые данные" для получения всего оплаченного времени (большие прямоугольники в таблице) + доп.услуг
и
"Запросить состояния компьютеров" для получения состояний компьютеров (маленькие точки в таблице). При нажатии на одну из них начинается передача соответствующей информации, сотояние чего отображается в верхнем окошке в текстовом виде и в виде заполнения "полосы состояния". После загрузки можно пользоваться всеми обычными средствами, например, создавать отчеты...

В виде "Список" (F4) текущее состояние компьютеров будет автоматически обновляться в реальном времени в течении всего подключения. При выделении компьютера будет показан список его процессов.

Можно посмотреть (и, при необходимости, принудительно завершить) процессы (запущенные программы) на удаленном администраторском компьютере.

Связь с удаленным сервером осуществляется через стандартный чат (Вид "Список" F4). При отправке сообщения с помощью Ctrl+Enter оно отправляется как Быстрое сообщение, вид которого можно менять вручную дописывая параметры. С работающего сервера (обычно к которому производится подключение) сообщения чата отправляются всем подключенным серверам и выделенным клиентским компьютерам - что бы посетители не видели сообщения, предназначенные подключенному серверу, в списке компьютеров не должно быть выделенных. компьютеров.

Сетевые настройки

Сервер принимает соединения (может быть подключено любое количество) по TCP - порту 7698 (по умолчанию). Эта цифра меняется в файле CC.INI в разделе [Network] - параметр "Transmitter Port" (без кавычек).


Регистрация

Для предотвращения копирования программы применена следующая система : На "незнакомом" компьютере срок действия ограничен до 10 дней с момента первого запуска.

По окончании срока программа работать перестает, и выдает только одну табличку :

Осталось 9 дней.

Для снятия этого ограничения нужно сообщить нам Рег.номер, и ввести полученный код.

Состояние регистрационной информации можно посмотреть в меню Справка / Регистрация.

Как зарегистрировать программу ?

Запустите программу на том компьютере, на котором она должна будет работать !

В меню Справка выберите пункт Регистрация. В появившемся окошке выделите свой Регистрационный номер и скопируйте его (Ctrl+C). Напишите письмо по этому адресу, в которое вставьте (Ctrl+V) Рег. номер и ждите ответа. В течение нескольких дней Вам придет ответный код - опять запустите ClubContrl на том же компьютере и вставьте его в окошке регистрации в поле Код. Нажмите кнопку "Ввести код".


InetReporter

Система отправки состояния компьютеров на интернет-страницу клуба в виде картинок , показывающих содержимое экрана компьютера.

Пример использования - страница клуба SP-37 в Санкт-Петербурге http://clubcontrol.narod.ru/Clubs/1/ClubView.htm

При отправке на наш сайт clubcontrol.narod.ru в поле адрес должно быть "ftp.narod.ru", логин и пароль - пустые, директория = Clubs/

Параметр Автообновление - интервал автоматической отправки картинок в интернет. Значение 0 - не отправлять.

Нажав кнопку "Страница клуба", можно увидеть Ваши компьютеры.

Отправить сейчас - ручная отправка.


Настройки компьютеров

Все параметры клиентской части ClubControl можно просматривать и менять с сервера, таким образом осуществляя клонирование компьютеров.

Настройки клиентов доступны из меню (раздел Клиент пункт Настройки). При выборе этого пункта появляется окно настроек и сразу запрашиваются параметры с первого выделенного компьютера. Это окно не мешает производить другие действия, как добавление времени и т.д., однако при изменении выделения компьютеров будут запрашиваться параметры первого выделенного в соответствии с отмеченными разделами настроек.

Галочки у каждого раздела означают, будут ли данные из этих разделов запрашиваться или устанавливаться. - Параметры из неотмеченного раздела на клиенте при установке и на сервере при запросе останутся неизмененными .

Для быстрой установки / очистки всех галочек используйте галочку "Все отметки V/X".

В списке "Отображать №" появляются все выделенные и подключенные компьютеры. Цифра в этом окошке - номер компьютера, у которого были запрошены его параметры. При выделении другого клиента данные запрашиваются у него.

Используя эти средства, можно собрать нужные параметры с нужных компьютеров и размножить их по всем (или некоторам) машинам.

Звездочка (*) у названия раздела означает, что установка данных и этого раздела возможна только при вводе пароля (меняется в настройках сервера).

При нажатии кнопки Ок данные из отмеченных разделов буду отосланы выделенным компьютерам.

Описание разделов

  • Окончание времени
  • Интерфейс
  • Заставка
  • Разделы
  • Почта
  • Информация при загрузке
  • Бегущая строка
  • Предупреждения
  • Безопасность
  • Запрещенные процессы
  • Прокси-сервер
  • Internet Explorer


Окончание времени

Этот раздел относится к действиям программы после того, как заканчивается время у клиента и компьютер блокируется.

На кнопке "До свидания ..." виден обратный отсчет времени до перезагрузки компьютера при установленной галочке "Перезагружать...". Нажатие на кнопку равноценно завершению отсчета. Время устанавливаемое здесь при окончании времени, задается параметром "Задержка перед перезагрузкой".

Если посетитель хочет доплатить и жмет соответствующую кнопку, к отсчитываемому времени прибавляются секунды из параметра "Прибавлять при нажатии кнопки Доплатить ".

Если игрок хочет проголосовать, то дополнительное время дается в соответствии с параметром "Прибавлять при заполнении рейтинга"


IE

Microsoft Internet Explorer

Различные запреты для Internet Exlporer'a позволяют обезопасить компьютер от посетителей.


Почта

Настройки почтового клиента - SMTP сервер/порт и существующая там учетная запись.


Бегущая строка

Набор сообщений, проползающих внизу экрана на клиентском компьютере.


Информация при загрузке

Информация при загрузке игр

При загрузке игр иногда есть достаточно времени, что-бы прочитать текст, показанный в специальном окошке :

Тут в случайном порядке выводятся RTF-файлы, создавать и редактировать которые можно с сервера.

Создать создаст новый файл, текст в котором можно изменить в нижнем окошке просто написав там что-то, но лучше Открыть файл во внешнем редакторе и использовать размер/цвет/стиль шрифта. Можно скопировать форматированный текст из внешнего редактора и вставить его через буфер обмана windows.


Настройка разделов

Разделы

Атрибут скрытый обозначает , что раздел будет показываться клиенту только при оплате тарифа с таким же названием.

Атрибут 1 игра - из этой папки возможен одновременный запуск только одной программы. Небходимо для игровых папок, что-бы на компьютере не висело по запущенных 5 игр ! По умолчанию включено для новых папок, поэтому при создании тарифов типа "оффис" лучше эту галочку убрать.

Галочки ставятся/снимаются двойным щелчком мыши.

При удалении раздела (и отправке на клиента по кнопке ОК) будет удалена вся локальная папка с ярлыками.


Предупреждения

За заданное время до окончания времени будет выдано предупреждение. Формат сообщений см. в Быстрых Сообщениях.


SMTP-сервер

Для работы некоторых систем ClubControl (Быстрая почта, Отправка отчетов по e-mail) необходим внешний smtp-сервер с разрешенной ретрансляцией (relay).

Рекомендуется установить в клубе SMTP-сервер и использовать его. В Windows 2000 и выше легко использовать IIS. Далее рассмотрим пример настройки именно IIS smtp в Windows XP.

"Control Panel" -> "Administrative Tools" -> "Internet Information Services"

Если пункта "Internet Information Services" нет, значит не установлен IIS. Установить это можно из "Control Panel" -> "Add or Remove Programms"

В списке компонентов IIS (слева) выделите "Default SMTP Virtual Server" и, вызвав контекстное меню нажатием правой кнопки мыши, выберите пункт "Properties". Если такого пункта нет, то не установлен SMTP-сервер. Установить его можно из "Add or Remove Programms" (компонент IIS).

Основные настройки SMTP-сервера

Далее - закладка "Access"

Настройки доступа SMTP-сервера

Далее - кнопка "Relay"

Настройки ретрансляции (relay) SMTP-сервера

Здесь выберите опции "All except the list below" и "Allow all computers which successfully authenticate to relay". Все, теперь адрес этого компьютера можно использовать в настройках как "smtp-сервер".